Connecting to the VPN

Overview

The VPN, also known as Virtual Private Network, is used to connect your machine to North Central's network so that you are able to access any systems without the need for being on campus. These systems include Colleague servers, Network Drives, and more. Our VPN is through a company called GlobalProtect. This article will walk you through connecting to the VPN client.

If you need assistance installing the VPN Client, please see Installing the GlobalProtect VPN Client.

Connecting to the VPN

Windows

1. Select the arrow on the right side of the taskbar and look for the Globe icon. Select it. 

              - Alternatively, you can search for GlobalProtect using the Search Box in the Task Bar. 

              

2. Enter vpn.northcentral.edu in the portal address field and select connect.

     - If you just see a Connect button, click Connect, as your client is automatically mapped to the NCU Portal.

     

3. Enter your NCU Username and Password in the designated fields and select Sign in.

4. When connected, it will show so in a pop-up window or within an icon located in the hidden icons section of the taskbar. 

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If you are attempting to access Network Drives, you should be able to view them as normal. If they are not appearing, please visit How to Map Network Drives in Windows.


Apple

1. Select the GlobalProtect Icon in the top menu bar. 

               - Alternatively, you can open it by selecting it from the Applications folder. 

               

2. Enter vpn.northcentral.edu as the portal address and select connect.

3. Enter your NCU Username and Password and select Sign in to connect to the VPN. 

4. Once connected, it will show you inside of a popup. 

 

Stuck on Connecting

After you enter the portal address (vpn.northcentral.edu), there is a chance that the client may just continually attempt to connect, and say Still working. If this is the case, you will need to ensure that the Palo Alto System Software is allowed to run on your Mac. Note: Palo Alto is the company that runs our firewall and vpn client. 

Cause
According to Technical Note TN2459 from Apple, "macOS High Sierra 10.13 introduces a new feature that requires user approval before loading newly-installed third-party kernel extensions (KEXTs)."

Additionally, Technical Note TN2459 from Apple indicates, "[t]his feature enforces that only kernel extensions approved by the user will be loaded on a system."
 

Resolution

  1. Open System Preferences.
  2. Open Security and Privacy (Should be on top row).
  3. Ensure you are in General Tab.
  4. Look for message stating that software from Palo Alto Networks is being blocked
  5. Click Allow
  6. Re-attempt to connect to the VPN.

If you are unable to click allow, please call the Service Desk at 6112.343.4170.

 

Requesting Assistance

If you require assistance connecting to the VPN, please submit a ticket. 

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Details

Article ID: 104704
Created
Tue 4/7/20 4:47 PM
Modified
Fri 1/15/21 4:04 PM
Audience
Employees
Faculty
IT Staff
Staff